1) Go to > Active Project Properties >C/C++ Build, in “Behaviour”, check “Use parallel build” and enter the number of cores for parallel jobs
2) Go to > Active Project Properties >C/C++ Build>Settings, in “Tool Settings” under “/ARM-GCC C Compiler/Miscellaneous” check “Enable ccache to speed up the re-compilation”