infineon4engineers Facebook

infineon@google+ Google+

infineon@linkedin linkedin

infineon4engi@twitter twitter

infineon@youtube youtube

+ Reply to Thread
Results 1 to 3 of 3

Thread: Ethernet Demo on TC3xx starter kit

  1. #1
    Beginner Beginner Sabulanis is on a distinguished road
    Join Date
    Apr 2018

    Ethernet Demo on TC3xx starter kit

    Iím using a 2nd generation AURIX TC3xx starter kit (TriBoard) and tried to run the Ethernet Demo supplied with the iLLD TC39A without success.
    The Demo can be compiled and programmed, but the communication with the PHY PEF7071 mounted on the board seems to be unsuccessful as they program will wait for the Transmission-Complete-Interrupt to be set which never happens.
    The functions provided by the IfxEth library seem to have no effect, reading out the registers of the PHY using the IfxEth_Phy_Pef7071 library shows that there are no changes done.
    The mdio read and write functions provided by IfxEth_Phy_Pef7071 work as they should.

  2. #2
    Beginner Beginner vitorroriz is on a distinguished road
    Join Date
    Apr 2018
    I am facing the same issue using the TC297.

    As I mentioned in my thread:

    By debugging I realized that the DMA never gets the chance to access the Tx Buffer, as it is always setting TU = 1 (TU stands for Transmit Buffer Unavailable) on the DMA Reg5 (Status Reg). This happens when the DMA accesses the Tx Descriptor and reads Own bit = 0, what means that the Host owns the Descriptor (and therefore the DMA does not own it).

    I have already checked the Register TDESLA_32BIT that holds the Addr of the Descriptor list and it is holding the correct addr. I have also already verified that the Own bit is being correctly set to Own = 1 before the poll demand on the DMA, delivering the ownership of the descriptor to the DMA.

  3. #3
    Beginner Beginner audiolines is on a distinguished road
    Join Date
    May 2018
    I was still unable to communicate over Ethernet on TC297 or TC3xx Starter kit.
    I also read the user manual and cross checked the Register Values.

    Still, there is nothing from the PHY.. I also noticed the issue vitorrriz is talking about and tried to even code my own descriptors just for a sanity check.
    Still, nothing.

    Any ideas on how to solve this? Is it working for you?

+ Reply to Thread

Tags for this Thread


All content and materials on this site are provided ďas isď. Infineon makes no warranties or representations with regard to this content and these materials of any kind, whether express or implied, including without limitation, warranties or representations of merchantability, fitness for a particular purpose, title and non-infringement of any third party intellectual property right. No license, whether express or implied, is granted by Infineon. Use of the information on this site may require a license from a third party, or a license from Infineon.

Infineon accepts no liability for the content and materials on this site being accurate, complete or up- to-date or for the contents of external links. Infineon distances itself expressly from the contents of the linked pages, over the structure of which Infineon has no control.

Content on this site may contain or be subject to specific guidelines or limitations on use. All postings and use of the content on this site are subject to the Usage Terms of the site; third parties using this content agree to abide by any limitations or guidelines and to comply with the Usage Terms of this site. Infineon reserves the right to make corrections, deletions, modifications, enhancements, improvements and other changes to the content and materials, its products, programs and services at any time or to move or discontinue any content, products, programs, or services without notice.