infineon4engineers Facebook

infineon@google+ Google+

infineon@linkedin linkedin

infineon4engi@twitter twitter

infineon@youtube youtube

+ Reply to Thread
Results 1 to 7 of 7

Thread: Ethernet Demo - Outbound communication

  1. #1
    New Member New Member Claas is on a distinguished road
    Join Date
    Jun 2016
    Posts
    6
    Points
    35

    Ethernet Demo - Outbound communication

    Hello

    (I hope somebody can help me with this thread)

    I am trying to enable ethernet communication on an Infineon Aurix Tricore, specifically TC29x. To this end I am using the Aurix SW_framework_tools and the ILLD supplied by Infineon on their Aurix workspace page (if you ask for access).
    In the ILLD package and demo, they have a ethernet demo with loopback_mode enabled. This demo works fine on the board. I then wanted to send out a package to another machine to enable ethernet communication. I have tried fiddling around with settings, using wireshark with cross-over-cable, wireshark with switch, against windows and linux pc's. With no packages received
    I am therefore unsure if the demo has the pinmap configured correctly, and/or if some settings I have missed should be changed. My question is therefore if anyone has enabled ethernet communication using the infineon tools, and can guide me?

    Tools
    I have chosen the HighTec toolchain using the debuger UDE, all are from the free tools available on Infineon.

    Board
    Infineon Aurix Tricore TC299 Starter Kit.

  2. #2
    New Member New Member jaybshah92 is on a distinguished road
    Join Date
    Nov 2016
    Posts
    2
    Points
    45

    Exactly same problems

    Quote Originally Posted by Claas View Post
    Hello

    (I hope somebody can help me with this thread)

    I am trying to enable ethernet communication on an Infineon Aurix Tricore, specifically TC29x. To this end I am using the Aurix SW_framework_tools and the ILLD supplied by Infineon on their Aurix workspace page (if you ask for access).
    In the ILLD package and demo, they have a ethernet demo with loopback_mode enabled. This demo works fine on the board. I then wanted to send out a package to another machine to enable ethernet communication. I have tried fiddling around with settings, using wireshark with cross-over-cable, wireshark with switch, against windows and linux pc's. With no packages received
    I am therefore unsure if the demo has the pinmap configured correctly, and/or if some settings I have missed should be changed. My question is therefore if anyone has enabled ethernet communication using the infineon tools, and can guide me?

    Tools
    I have chosen the HighTec toolchain using the debuger UDE, all are from the free tools available on Infineon.

    Board
    Infineon Aurix Tricore TC299 Starter Kit.
    I have the exact same issue. Has anyone figured out how to do this?

  3. #3

  4. #4
    Beginner Beginner audiolines is on a distinguished road
    Join Date
    May 2018
    Posts
    7
    Points
    100
    Hello All,

    Before reading this post, I also noticed the same issue posted in the link from vlylin.
    However I still get absolutely nothing from the PHY. Has this issue been solved?

  5. #5
    New Member New Member vivekrsingh20 is on a distinguished road
    Join Date
    Jan 2019
    Posts
    16
    Points
    160
    Quote Originally Posted by Claas View Post
    Hello

    (I hope somebody can help me with this thread)

    I am trying to enable ethernet communication on an Infineon Aurix Tricore, specifically TC29x. To this end I am using the Aurix SW_framework_tools and the ILLD supplied by Infineon on their Aurix workspace page (if you ask for access).
    In the ILLD package and demo, they have a ethernet demo with loopback_mode enabled. This demo works fine on the board. I then wanted to send out a package to another machine to enable ethernet communication. I have tried fiddling around with settings, using wireshark with cross-over-cable, wireshark with switch, against windows and linux pc's. With no packages received
    I am therefore unsure if the demo has the pinmap configured correctly, and/or if some settings I have missed should be changed. My question is therefore if anyone has enabled ethernet communication using the infineon tools, and can guide me?

    Tools
    I have chosen the HighTec toolchain using the debuger UDE, all are from the free tools available on Infineon.

    Board
    Infineon Aurix Tricore TC299 Starter Kit.

    hi, can you please help me out, am trying to run the ethernet demo code on TC234 but its not getting run, the problem is that while using UDE and debugging it The programme gets stuck in

    Code:
    ** \defgroup IfxLld_Cpu_Intrinsics_Gnucsingle_assembly Insert Single Assembly Instruction
     The next table provides an overview of the intrinsic functions that you can use to insert a single assembly
     instruction.You can also use inline assembly but these intrinsics provide a shorthand for frequently used
     assembly instructions.
     * \ingroup IfxLld_Cpu_Intrinsics_Gnuc
     * \{
     */
    
    /** Insert DEBUG instruction
     */
    IFX_INLINE void Ifx__debug(void)
    {
        __asm__ volatile ("debug" : : : "memory");
    }
    please help me out.

  6. #6
    Beginner Beginner SKG238234 is on a distinguished road
    Join Date
    Jan 2019
    Posts
    4
    Points
    80
    hi vivek

    did u find any solution ?

  7. #7
    New Member New Member vivekrsingh20 is on a distinguished road
    Join Date
    Jan 2019
    Posts
    16
    Points
    160
    Quote Originally Posted by SKG238234 View Post
    hi vivek

    did u find any solution ?
    Hi,
    Thanks for asking at least, because these days was fedup seeing no one is viewing my message. Atleast someone is able to see me.

    Coming back to your question, am afraid to say No.

    But while continuous debugging I found out that after executing these line of codes

    Code:
    void IfxEth_enableModule(void)
    {
        {
            uint16 l_TempVar = IfxScuWdt_getCpuWatchdogPassword();
            IfxScuWdt_clearCpuEndinit(l_TempVar);
            ETH_CLC.U = 0;
            IfxScuWdt_setCpuEndinit(l_TempVar);
        }
    }
    the UDE gets stuck in this,

    Code:
    /** Insert DEBUG instruction
     */
    IFX_INLINE void __debug(void)
    {
        __asm__ volatile ("debug" : : : "memory");
    }
    But now I don't know why this is happening, am new to AURIX, infact am new to this embedded field also, but am still trying to find out the solution of this.

    I told you where the problem is, now you too try to find its solution, and to other friends over here, please help me and him out.

    we/I need it to work ASAP

+ Reply to Thread
Disclaimer

All content and materials on this site are provided “as is“. Infineon makes no warranties or representations with regard to this content and these materials of any kind, whether express or implied, including without limitation, warranties or representations of merchantability, fitness for a particular purpose, title and non-infringement of any third party intellectual property right. No license, whether express or implied, is granted by Infineon. Use of the information on this site may require a license from a third party, or a license from Infineon.


Infineon accepts no liability for the content and materials on this site being accurate, complete or up- to-date or for the contents of external links. Infineon distances itself expressly from the contents of the linked pages, over the structure of which Infineon has no control.


Content on this site may contain or be subject to specific guidelines or limitations on use. All postings and use of the content on this site are subject to the Usage Terms of the site; third parties using this content agree to abide by any limitations or guidelines and to comply with the Usage Terms of this site. Infineon reserves the right to make corrections, deletions, modifications, enhancements, improvements and other changes to the content and materials, its products, programs and services at any time or to move or discontinue any content, products, programs, or services without notice.