infineon4engineers Facebook

infineon@google+ Google+

infineon@linkedin linkedin

infineon4engi@twitter twitter

infineon@youtube youtube

+ Reply to Thread
Results 1 to 9 of 9

Thread: DAVE 4 doesn't remember opened files

  1. #1
    New Member New Member obetz is on a distinguished road
    Join Date
    Oct 2013
    Location
    Munich
    Posts
    67
    Points
    190

    DAVE 4 doesn't remember opened files

    Hi All,

    "restore editor state" is checked, but DAVE 4 closes all my open files briefly after startup.

    Does anybody else observe the same error behaviour?

    Any solutions / workarounds?

    Oliver

  2. #2
    Advanced Advanced Daryl Neo is on a distinguished road
    Join Date
    Nov 2011
    Location
    Singapore
    Posts
    373
    Points
    3468.75
    Click image for larger version

Name:	CEPreference.JPG
Views:	2
Size:	75.6 KB
ID:	2013Hi Oliver,

    Can you go Windows -> Preferences --> DAVE --> DAVE CE Preferences:
    Uncheck the option to "Close all opened editors on active project switch"

    This option is selected by default. You can uncheck this to prevent the open files to be closed.

    Regards,
    Daryl

  3. #3
    New Member New Member obetz is on a distinguished road
    Join Date
    Oct 2013
    Location
    Munich
    Posts
    67
    Points
    190
    Thanks for the solution!

    I hadn't expected such a setting...

  4. #4
    Advanced Advanced Daryl Neo is on a distinguished road
    Join Date
    Nov 2011
    Location
    Singapore
    Posts
    373
    Points
    3468.75
    You're welcome!

  5. #5
    Beginner Beginner Herbert747 is on a distinguished road
    Join Date
    Aug 2017
    Location
    German
    Posts
    5
    Points
    120

    Dave 4.4.2 : After Restart all files are closed

    Why is this problem in the new version 4.4.2?
    See the settings with screenshots (attachments).
    After every new start of Dave all the files were closed!
    Why is that?
    And the next:
    Every restart the backscreen colour is black!!
    I must change the perspective and after that the backcolour is ok.
    It seems there are angry bugs in 4.4.x that were not in the preversion 4.3.2.
    ?????? ?????? PreferencesEditor_4.4.2JPG.JPG‎  

  6. #6
    Beginner Beginner Herbert747 is on a distinguished road
    Join Date
    Aug 2017
    Location
    German
    Posts
    5
    Points
    120

    Dave loses the backcolour settings , too.

    Attachment with screenshot wrong backcolour after start of dave.
    ?????? ?????? Wrongbackcolour.JPG‎  

  7. #7

    Infineon Employee
    Infineon Employee
    jferreira will become famous soon enough
    Join Date
    Oct 2012
    Posts
    441
    Hi,

    Are you using a custom Eclipse color theme?

    Regards,
    Jesus
    The views expressed here are my personal opinions, have not been reviewed or authorized by Infineon and do not necessarily represent the views of Infineon.

  8. #8
    Beginner Beginner Herbert747 is on a distinguished road
    Join Date
    Aug 2017
    Location
    German
    Posts
    5
    Points
    120
    No, I use no color theme.
    I used the old version 4.3.2 the last 15 month.
    Last week I installed the newer version 4.4.2. After that I removed the older 4.3.2.
    Only Dave was installed, no other things, no plugins.

    And since this installation 4.4.2 I get this issues:
    1. After restart all editor Tabs are closed.
    2. The wrong backcolor (see screenshot).

  9. #9

    Infineon Employee
    Infineon Employee
    jferreira will become famous soon enough
    Join Date
    Oct 2012
    Posts
    441
    Hi,


    For the tabs issue please check https://www.infineonforums.com/threa...ll=1#post18297
    In the case of the wrong background color, we have never experienced it or got reported before.
    Which OS are you using?
    Do you use an special color theme in Windows?
    Could you create a new workspace and check whether the issue persists?

    regards,
    Jesus
    The views expressed here are my personal opinions, have not been reviewed or authorized by Infineon and do not necessarily represent the views of Infineon.

+ Reply to Thread

Tags for this Thread

Disclaimer

All content and materials on this site are provided “as is“. Infineon makes no warranties or representations with regard to this content and these materials of any kind, whether express or implied, including without limitation, warranties or representations of merchantability, fitness for a particular purpose, title and non-infringement of any third party intellectual property right. No license, whether express or implied, is granted by Infineon. Use of the information on this site may require a license from a third party, or a license from Infineon.


Infineon accepts no liability for the content and materials on this site being accurate, complete or up- to-date or for the contents of external links. Infineon distances itself expressly from the contents of the linked pages, over the structure of which Infineon has no control.


Content on this site may contain or be subject to specific guidelines or limitations on use. All postings and use of the content on this site are subject to the Usage Terms of the site; third parties using this content agree to abide by any limitations or guidelines and to comply with the Usage Terms of this site. Infineon reserves the right to make corrections, deletions, modifications, enhancements, improvements and other changes to the content and materials, its products, programs and services at any time or to move or discontinue any content, products, programs, or services without notice.