TC4xx promo banner Banner_Aurix_Competition Banner_AURIX_Security-Solution Banner_AURIX_Safety_Products ShieldBuddy TC275 Banner_AURIX_DevelopmentStudio


+ Reply to Thread
Results 1 to 8 of 8

Thread: [AURIX2G] [Power On Reset] TC387QP Start -Up Issue

  1. #1
    New Member New Member Goutham is on a distinguished road
    Join Date
    Feb 2020
    Posts
    5
    Points
    40

    [AURIX2G] [Power On Reset] TC387QP Start -Up Issue

    Dear Sir/Madam,

    I am facing an issue with TC387 startup in EV Board. The problem is, when I connect the device with Lauterbach and flash my Hex/Sre/Elf File, it works properly.

    But when I de-attach the Lauterbach JTAG, my Application/Software does not run after Power OFF and On.

    Could you please clarify me that what possibly goes wrong on Power OFF and ON without Debugger attached? Is there any configuration which I am missing?


    NOTE: Valid BMHD is programmed.

    Thanks and Regards
    Goutham

  2. #2
    Advanced Advanced UC_wrangler will become famous soon enough
    Join Date
    Jun 2019
    Posts
    438
    Points
    9100
    Hi Goutham. The most common cause for this type of problem is that by default, the watchdog system is suspended when a debugger is connected. Your code may not be servicing / disabling the watchdog.

    Try debugging with SYStem.Option.WDTSUS OFF. See this post:
    https://www.infineonforums.com/threa...ll=1#post17656

  3. #3
    New Member New Member Goutham is on a distinguished road
    Join Date
    Feb 2020
    Posts
    5
    Points
    40
    Hi UC_Wrangler,

    Thanks for your reply .

    As I said earlier, there are no issues when we are using debugger.

    We want to test our code in standalone mode (without debugger).

    Are there any additional Power On Reset settings/configurations to be done ?

    Thanks and Regards
    Goutham

  4. #4
    Advanced Advanced UC_wrangler will become famous soon enough
    Join Date
    Jun 2019
    Posts
    438
    Points
    9100
    Hi Goutham. I understand there are no issues with the debugger - and that may because the watchdogs are disabled. Please try SYStem.Option.WDTSUS OFF and let us know if your application still works with the debugger connected.

    If the application stops working in the debugger, then your application needs to either service or disable the watchdogs.

  5. #5
    New Member New Member Goutham is on a distinguished road
    Join Date
    Feb 2020
    Posts
    5
    Points
    40
    Hi UC_wrangler,

    I tried making SYStem.Option.WDTSUS OFF and the application is still working with the debugger connected.

  6. #6
    Advanced Advanced UC_wrangler will become famous soon enough
    Join Date
    Jun 2019
    Posts
    438
    Points
    9100
    Hi Goutham. Thanks for ruling that out.

    Next: can you post the content of your UCB_BMHD0_ORIG at 0xAF400000-0xAF4001FF? Also, what value is in DMU_HF_CONFIRM0?

  7. #7
    New Member New Member Goutham is on a distinguished road
    Join Date
    Feb 2020
    Posts
    5
    Points
    40
    Hi UC_wrangler,

    I have sent the reply with the contents of UCB_BMHD0_ORIG and DMU_HF_CONFIRM0.

    But this forum is not allowing me to do so as the information is sensitive.

    It is showing the message " Thank you for posting! Your post will not be visible until a moderator has approved it for posting."

  8. #8
    New Member New Member Goutham is on a distinguished road
    Join Date
    Feb 2020
    Posts
    5
    Points
    40
    Hi UC_Wrangler,

    The issue got resolved.

    Previously I had serviced only CPU watchdog hence the issue remained unresolved.

    After servicing of both CPU and Safety Watchdogs , the issue of power on reset got resolved.

    With Regards
    Goutham

+ Reply to Thread

Tags for this Thread

Disclaimer

All content and materials on this site are provided “as is“. Infineon makes no warranties or representations with regard to this content and these materials of any kind, whether express or implied, including without limitation, warranties or representations of merchantability, fitness for a particular purpose, title and non-infringement of any third party intellectual property right. No license, whether express or implied, is granted by Infineon. Use of the information on this site may require a license from a third party, or a license from Infineon.


Infineon accepts no liability for the content and materials on this site being accurate, complete or up- to-date or for the contents of external links. Infineon distances itself expressly from the contents of the linked pages, over the structure of which Infineon has no control.


Content on this site may contain or be subject to specific guidelines or limitations on use. All postings and use of the content on this site are subject to the Usage Terms of the site; third parties using this content agree to abide by any limitations or guidelines and to comply with the Usage Terms of this site. Infineon reserves the right to make corrections, deletions, modifications, enhancements, improvements and other changes to the content and materials, its products, programs and services at any time or to move or discontinue any content, products, programs, or services without notice.