infineon4engi@twitter infineon@linkedin infineon4engineers infineon@youtube
twitter Facebook Linkedin Youtube

+ Reply to Thread
Results 1 to 2 of 2

Thread: I2C Communication with TLE493DW2B6

  1. #1
    New Member New Member pvint is on a distinguished road
    Join Date
    Jan 2020
    Posts
    1
    Points
    15

    I2C Communication with TLE493DW2B6

    Good day,

    I've been trying without success to communicate with my TLE493D devices (I have the A0).

    When I scan the I2C bus using a Raspberry Pi or ESP32 the device "sees" it at 0x35. Datasheet specifies that it is actually at 0x6A (read) and 0x6B (write). I have tried to write and/or read, but always receive 0xFF back for all bytes.

    I have attempted to read and write in single bytes as well as in two byte words, but no luck. I have also tried writing to the config register to set it to single byte, but I am still unable to read anything on any of the aforementioned addresses (I've been mostly focusing on simply trying to read back the config register).

    The board I am using is a custom PCB which simply contains the TLE493D, I2C pullups and decoupling cap. I have looked at the SDA/SCL signals on the scope and they look perfect (nice sharp rise and fall times), and since this seems to be a common issue, I haven't yet tried to decode the I2C signals.


    The more I dig into it I swear the more I get stumped... It really appears to me that I should be able to write a config value to 0x10 to set it as single byte and without INT etc. and then simply read the values, but I cannot get it to go. When I try to write to 0x6A using i2cset on the Pi it I get a "write failed" message (or similar message).

    I have tried without success to use the Arduino code from github (after some code changes I can get it to compile, but it also seems to always read 0xFF from every register.

    I'm really keen to get this working, as it really seems like the right sensor for my application, so any help is massively appreciated!

    Paul

  2. #2
    Beginner Beginner turboscrew2 is on a distinguished road
    Join Date
    Apr 2020
    Posts
    2
    Points
    50
    Have you checked for possible error states of the I2C controller?
    When TLE493D starts, it starts sending interrupts via the clock line, and that tends to mess up with I2C controllers.
    I managed to get it working by sending a mode change to non-interrupting mode, before the TLE493D tried to interrupt.

+ Reply to Thread
Disclaimer

All content and materials on this site are provided “as is“. Infineon makes no warranties or representations with regard to this content and these materials of any kind, whether express or implied, including without limitation, warranties or representations of merchantability, fitness for a particular purpose, title and non-infringement of any third party intellectual property right. No license, whether express or implied, is granted by Infineon. Use of the information on this site may require a license from a third party, or a license from Infineon.


Infineon accepts no liability for the content and materials on this site being accurate, complete or up- to-date or for the contents of external links. Infineon distances itself expressly from the contents of the linked pages, over the structure of which Infineon has no control.


Content on this site may contain or be subject to specific guidelines or limitations on use. All postings and use of the content on this site are subject to the Usage Terms of the site; third parties using this content agree to abide by any limitations or guidelines and to comply with the Usage Terms of this site. Infineon reserves the right to make corrections, deletions, modifications, enhancements, improvements and other changes to the content and materials, its products, programs and services at any time or to move or discontinue any content, products, programs, or services without notice.