infineon4engineers Facebook

infineon@google+ Google+

infineon@linkedin linkedin

infineon4engi@twitter twitter

infineon@youtube youtube

Search:

Type: Posts; User: Petru S

Search: Search took 0.00 seconds.

  1. Replies
    1
    Views
    1,272

    Hey Zain, Give a shot to Segger RTT, maybe it...

    Hey Zain,

    Give a shot to Segger RTT, maybe it will enough for your project.
    Regarding semihosting, there is a thread somewhere in this forum explaining how to use it correctly but you will have...
  2. Replies
    1
    Views
    877

    Hello, Did you tried to regenerate the code,...

    Hello,

    Did you tried to regenerate the code, rebuild and flash the uC?
    What was the initial value that you set in DAVE ... before the 200KHz?

    Best regards,
    Petru S
  3. Thread: Xmc debug

    by Petru S
    Replies
    2
    Views
    1,828

    Hello Andi, Where is this "Launch Terminal"...

    Hello Andi,

    Where is this "Launch Terminal" window?
    Thank you. :)

    Best regards,
    Petru
  4. Dave 4.2.4 - ETH_LWIP app version 4.0.6 problem

    Hi friends,

    I had a LWIP server in Dave 4.2.4 which was working well. I performed Dave Apps Updates and the ETH_LWIP app upgraded itself from 4.0.4 to 4.0.6. Now - using the same code - i can...
  5. Hi Daryl, I'm having the same problem as vdel....

    Hi Daryl,

    I'm having the same problem as vdel.

    I added an SPI_MASTER (version 4.3.14) app to my project and after generating the code, I get the same error as vdel....
  6. Replies
    1
    Views
    1,141

    Hello fasgill, You can start with this:...

    Hello fasgill,

    You can start with this:...
  7. Replies
    2
    Views
    1,613

    Hello, Do you need to control only one motor?...

    Hello,

    Do you need to control only one motor? Or a few of them in the same project?
    Do you need other features like communications or the entire project is focused on a single motor control...
  8. Thank you lerlacher, As expected it works...

    Thank you lerlacher,

    As expected it works quite reliably. However I don't quite get it when it send's a status message over a actual value message.
    The raw values that I get are between 4096D...
  9. Hello everyone, I'm having some trouble...

    Hello everyone,

    I'm having some trouble reading TLI4970 current sensor. I'm trying just to get the data from the sensor in a controlled way. I'm using XMC1100 (XMC 2 go) and DAVE 4.2.6.
    On the...
  10. I realize now that I forgot to specify that I am...

    I realize now that I forgot to specify that I am using DAVE 3.10 and not DAVE 4.2. ETH_LWIP is in DAVE 4.2 if I am not mistaking.
    In this stage, I can connect up to 10 clients simultaneously, but I...
  11. Hello Benjamin, Thank you for your reply! The...

    Hello Benjamin,

    Thank you for your reply!
    The controller doesn't get stuck, the board is still working properly with the other apps but not with TCP/IP.
    It doesn't give any error at all. The...
  12. Limited number of messages on TCP/IP communication

    Hello,

    I'm having some problems with TCP/IP communication between an XMC server and a Java client.
    I can send and receive TCP messages but only 5, after 5 messages my server doesn't receive...
  13. Replies
    0
    Views
    2,015

    SVN problems in DAVE 3.1.10

    Hello,

    I'm having some problems with sharing my project with other members of my team.
    I've set up an SVN server, it's accessible by my team but when I check out the project some of the header...
  14. Replies
    2
    Views
    3,977

    Hello sevctn, Can you help me with some more...

    Hello sevctn,

    Can you help me with some more details about active break?
    I'm assuming that the simplest way would be to stop the commutation and energize one coil, the inertia of the rotor will...
  15. Replies
    6
    Views
    3,749

    Hello Adriano, Thank you for your reply, I...

    Hello Adriano,

    Thank you for your reply, I will give a try to Simulink, I've downloaded and installed but haven't got the chance to work with it.
    For the moment I think I'm pretty close to what...
  16. Replies
    6
    Views
    3,749

    Hello Travis, Thank you for your reply. In a...

    Hello Travis,

    Thank you for your reply. In a nutshell I want to be able to write tests for my code, run those test make sure they work, add some more code, re-run the first tests and make sure...
  17. Replies
    6
    Views
    3,749

    Test Driven Development on XMC4500 and DAVE?

    Hello everyone,

    My projects are getting a little bit more complex and I would like to add TDD to the mix. So I have some questions, maybe somebody could point me in the right direction.
    Is there...
  18. Replies
    2
    Views
    2,241

    Hi Christianz, You can use Dave 3 project...

    Hi Christianz,

    You can use Dave 3 project BLDCBCH03 if you're on a tight constraint. I've done a DIY inverter and I'm using XMC4500+Dave 3 for control. My project it's still under development but...
  19. Replies
    5
    Views
    4,111

    Hi enigmaldc, Do you have a constraint about...

    Hi enigmaldc,

    Do you have a constraint about not using an interrupt? How about ADC? Check the ADC value and stop the PWM.
    Just an idea.

    Regards,
    Petru S.
  20. Replies
    1
    Views
    3,274

    Hi, If still interested, you can find Travis...

    Hi,

    If still interested, you can find Travis Hands On Training here:
    https://www.infineonforums.com/threads/1828-XMC_HOT-XMC4500-How-to-create-a-CGI-and-SSI-web-server-with-lwIP-stack

    Regards,
  21. Replies
    2
    Views
    1,891

    Hello viktoria, You cand download the examples...

    Hello viktoria,

    You cand download the examples from here:
    http://www.infineon.com/cms/en/product/promopages/aim-mc/DAVE_3_Support_Portal/DAVE_Example_Project_Download.html

    Hope it helps. :)
  22. Replies
    1
    Views
    3,149

    Hello, I think I've managed to get this...

    Hello,

    I think I've managed to get this problem sorted. As it turns out those error messages are the consequence of the problem and not the problem itself.
    I think the problem lies in the linker...
  23. Replies
    1
    Views
    3,149

    Webserver not working on F100x1024 AC?

    Hello,

    I'm trying to port the original Webserver DAVE project to a new chip which is used on the relax kit development board, but with not much succes.
    I'm using Device Migration tool inside DAVE...
Results 1 to 23 of 23
Disclaimer

All content and materials on this site are provided “as is“. Infineon makes no warranties or representations with regard to this content and these materials of any kind, whether express or implied, including without limitation, warranties or representations of merchantability, fitness for a particular purpose, title and non-infringement of any third party intellectual property right. No license, whether express or implied, is granted by Infineon. Use of the information on this site may require a license from a third party, or a license from Infineon.


Infineon accepts no liability for the content and materials on this site being accurate, complete or up- to-date or for the contents of external links. Infineon distances itself expressly from the contents of the linked pages, over the structure of which Infineon has no control.


Content on this site may contain or be subject to specific guidelines or limitations on use. All postings and use of the content on this site are subject to the Usage Terms of the site; third parties using this content agree to abide by any limitations or guidelines and to comply with the Usage Terms of this site. Infineon reserves the right to make corrections, deletions, modifications, enhancements, improvements and other changes to the content and materials, its products, programs and services at any time or to move or discontinue any content, products, programs, or services without notice.