PDA

View Full Version : [SOLVED] TLE9879 QXA40 communication problems with LIN Masters



bobypal
Aug 28th, 2019, 12:05 AM
Hi sir,

I am working on TLE9879 QXA40 and using the example code Sensorless FOC with LIN.
I am using two tools as LIN master. One is Microchip serial LIN Analyzer and the other one is CANoe. The controller is able to detect the LIN signal from Microchip tool but not from CANoe.

Although the identifier,baud rate (19200), data bytes and checksum types are same in both the tools.
I have taken the CRO traces of the LIN signal from both the tools. The only difference I can observe is the difference in the time of Break Field, due to which the total time of the LIN frame is also different.
Below are the details of the signals.

From CANoe Tool: Total frame time : 6.709 ms
Break field time: 953.612 micro sec

From Microchip tool : Total frame time : 6.4 ms
Break field time : 672 micro sec

The LIN 2.1 standard says that the break field should be at least 13 bit long and one break delimiter.

On calculating, the break field from microchip tools comes to be 13 bit and from CANoe tool is 18 bit. Both of them are following the standard.
What could be the issue in this case? And is there any provision in the example code of Sensorless FOC with LIN to change the limit on break field or tolerance, so that it starts accepting the frame from CANoe also?

4114411541164117

Fiz
Aug 28th, 2019, 11:55 PM
Hi Bobypal,

I moved your question to its own thread so it can found be more easily.
We will look into this and let you know as soon as possible when we were able to come up with a solution.

Best,
Fiz

Fiz
Oct 16th, 2019, 06:44 AM
Hi Bobypal,

This behavior is described in the User Manual rev1.4 page 635.

Please check the configuration of the BGSEL bitfield.
4216

Best,
Fiz