PDA

View Full Version : XMC 1300 Boot Kit - Memtool



TomTurbo
Sep 25th, 2013, 12:51 AM
Hi,

I'd like to change the boot mode of a XMC1300-Controller. The default mode of device on Boot Kit is "Debug" but I'd like to use it in "Productive" mode.
Unfortunately, I couldn't manage to connect with the Boot Kit using Memtool 4.5. At first, I've chosen this target configuration:

376

But when I try to connect, i get this message:


Message from component 'IMTMemtool' :
Can't connect to Target

Message from component 'MiniMonTargIntf' :
Can't connect target !

Message from component 'MiniMonTargIntf' :
Start monitor failed

Message from component 'MiniMonTargIntf' :
Bootstrap loader not responding !
Please check:
- Target power supply
- Communication cable
- Communication settings

Maybe, there are some required pin connections on the BootKit-Board I haven't mentioned...Can anybody help me to configure and to connect to the BootKit? :o

tys
Sep 26th, 2013, 07:15 PM
Hi,
In DAVE v3.1.8, there is a "BMI Get Set" button. If you clicked on that dialog box will appear and allow you to select the BMI value that you want to change, then you clicked the 'Set BMI' button on the dialog box, the XMC1300 device BMI value will be changed.

But by changing the BMI to "Productive" mode, that means you CANNOT download code or do debugging to the XMC1300 device anymore. Is that what you want ?
379

jr1m90
Sep 27th, 2013, 07:34 PM
Having had the same error message and question as TomTurbo, I can confirm that the "BMI Get Set" button in Dave 3.1.8 works for me.

Trying this on two boards, one worked immediately, the second worked only after I cleaned the PCB around where the XMC1x00 was mounted with some isopropyl alcohol. The second PCB has sufficient surface contamination to give a <100KOhm resistance between the debug pins, which was low enough to cause problems.